背景如下:
如下图所示,PC1和PC2分别属于VLAN 2和VLAN 3,通过接入层设备DeviceB接入汇聚层设备DeviceA。PC3属于VLAN 4,通过接入层设备DeviceC接入汇聚层设备DeviceA。DeviceC不做任何配置,当做HUB即插即用。汇聚层设备DeviceA作为PC1、PC2和PC3的网关,实现用户PC间的互访以及和上层设备的互连。
操作步骤
- 配置接入层设备DeviceB。
#创建VLAN。
<HUAWEI> system-view
[HUAWEI] sysname DeviceB
[DeviceB] vlan batch 2 3
#将接口加入相应VLAN。
[DeviceB] interface 10ge 1/0/2
[DeviceB-10GE1/0/2] portswitch
[DeviceB-10GE1/0/2] port link-type access
[DeviceB-10GE1/0/2] port default vlan 2
[DeviceB-10GE1/0/2] quit
[DeviceB] interface 10ge 1/0/3
[DeviceB-10GE1/0/3] portswitch
[DeviceB-10GE1/0/3] port link-type access
[DeviceB-10GE1/0/3] port default vlan 3
[DeviceB-10GE1/0/3] quit
[DeviceB] interface 10ge 1/0/1
[DeviceB-10GE1/0/1] portswitch
[DeviceB-10GE1/0/1] port link-type trunk
[DeviceB-10GE1/0/1] port trunk allow-pass vlan 2 3
[DeviceB-10GE1/0/1] quit
- 配置汇聚层设备DeviceA。
#创建VLAN。
<HUAWEI> system-view
[HUAWEI] sysname DeviceA
[DeviceA] vlan batch 2 to 5
#将连接DeviceB、DeviceC的接口加入相应VLAN。
[DeviceA] interface 10ge 1/0/2
[DeviceA-10GE1/0/2] portswitch
[DeviceA-10GE1/0/2] port link-type trunk
[DeviceA-10GE1/0/2] port trunk allow-pass vlan 2 3
[DeviceA-10GE1/0/2] quit
[DeviceA] interface 10ge 1/0/3
[DeviceA-10GE1/0/3] portswitch
[DeviceA-10GE1/0/3] port link-type access
[DeviceA-10GE1/0/3] port default vlan 4
[DeviceA-10GE1/0/3] quit
#配置VLANIF接口,作为用户PC的网关。
[DeviceA] interface vlanif 2
[DeviceA-Vlanif5] ip address 192.168.2.1 24
[DeviceA-Vlanif5] quit
[DeviceA] interface vlanif 3
[DeviceA-Vlanif5] ip address 192.168.3.1 24
[DeviceA-Vlanif5] quit
[DeviceA] interface vlanif 4
[DeviceA-Vlanif5] ip address 192.168.4.1 24
[DeviceA-Vlanif5] quit
将连接上层设备的接口加入相应VLAN。
[DeviceA] interface 10ge 1/0/1
[DeviceA-10GE1/0/1] portswitch
[DeviceA-10GE1/0/1] port link-type access
[DeviceA-10GE1/0/1] port default vlan 5
[DeviceA-10GE1/0/1] quit
#配置VLANIF
接口,实现内网网段到上层设备的访问。
[DeviceA] interface vlanif 5
[DeviceA-Vlanif5] ip address 192.168.5.1 24
[DeviceA-Vlanif5] quit
检查配置结果
执行命令display vlan
可以查看VLAN状态,
以DeviceB为例:
[DeviceB] display vlan 2
--------------------------------------------------------------------------------
U: Up; D: Down; TG: Tagged; UT: Untagged;
MP: Vlan-mapping; ST: Vlan-stacking;
#: ProtocolTransparent-vlan; *: Management-vlan;
MAC-LRN: MAC-address learning; STAT: Statistic;
BC: Broadcast; MC: Multicast; UC: Unknown-unicast;FWD: Forward; DSD: Discard;
--------------------------------------------------------------------------------VID Ports
--------------------------------------------------------------------------------2 UT:10GE1/0/2(U) 10GE1/0/3(U)TG:10GE1/0/1(U)VID Type Status Property MAC-LRN STAT BC MC UC Description
--------------------------------------------------------------------------------2 common enable default enable disable FWD FWD FWD VLAN 0002
#执行命令display port vlan
,查看接口上可以通过的VLAN信息,以DeviceB的接口10GE1/0/1为例:
[DeviceB] display port vlan 10ge 1/0/1
Port Link Type PVID Trunk VLAN List Port Description
---------------------------------------------------------------------------------------------------------------
10GE1/0/1 trunk 1 2-3
配置脚本
• DeviceA
sysname DeviceAvlan batch 2 to 5interface Vlanif2
ip address 192.168.2.1 255.255.255.0interface Vlanif3
ip address 192.168.3.1 255.255.255.0 interface Vlanif4
ip address 192.168.4.1 255.255.255.0 interface Vlanif5
ip address 192.168.5.1 255.255.255.0 //上行出口interface 10GE1/0/1
port link-type access
port default vlan 5interface 10GE1/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 3interface 10GE1/0/3
port link-type access
port default vlan 4return
• DeviceB
sysname DeviceBvlan batch 2 to 3interface 10GE1/0/1port link-type trunk
port trunk allow-pass vlan 2 to 3 interface 10GE1/0/2
port link-type access
port default vlan 2 interface 10GE1/0/3
port link-type access
port default vlan 3 return
• DeviceC
sysname DeviceCvlan batch 4
interface 10GE1/0/1
port link-type access
port default vlan 4interface 10GE1/0/2
port link-type access
port default vlan 4 return
日常学习总结