网络PPP协议802.11协议以太网协议IPV4协议在思科模拟器的实现

1)PPP协议

f0da631d88cb4d7b84b927ea9ffe82eb.png

1. 选择2620系列交换机,添加WIC-2t模块,具有两个serial串行接口;

28ebc3ee39c6475fa3d4a52e7760bcf5.png

2.Router>enable:进入特权模式

Router#configure terminal:全局配置模式

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface serial 0/0:进入0号串行接口

Router(config-if)#ip address 192.168.1.1 255.255.255.0:配置IP

Router(config-if)#clock rate 128000:设置0号串行接口作为DCE设备,向DTTE端提供速率为128000的时钟

Router(config-if)#encapsulation ppp:封装PPP协议;

Router(config-if)#shutdown:暂时停用端口,以便后续打开然后捕获报文

26ffa947ed5d4716b32e412fa4f4f2e5.png

3.另一个路由器配置

Enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface serial 0/0

Router(config-if)#ip address 192.168.1.2 255.255.255.0

Router(config-if)#encapsulation ppp

Router(config-if)#shutdown

8dfe344f8b234fda83b877bc2808ce2a.png

输入 no shutdown启用端口;

(2)以太网协议分析:

e0497900758444eea718af2691ced77b.png

1.

Router>enable

Router#confi

Router#configure te

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#inter

Router(config)#interface fa

Router(config)#interface fastEthernet 0/0

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Router(config-if)#no shutdown

3ed05a00fc5040c0901c5c4acdc604ca.png

2.

Router>en

Router>enable

Router#configure

Router#configure te

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#inter

Router(config)#interface fa

Router(config)#interface fastEthernet 0/0

Router(config-if)#ip address 192.168.1.2 255.255.255.0

Router(config-if)#no shutdown

b62358eec0ef49b29a1acafed61e4e10.png

2. 路由器之间使用ping命令测试连通性:

45d90ff69fe847d9a79d20f8f69016f4.png

(3)802.11协议分析:

1)在802.11无线协议标准中,定义了基本服务集BSS和拓展服务集ESS:

BSS基本服务集:由无线站及中心站组成;

(固定站)中心站称为access point接入点AP;没有AP的BSS称为自组织体系结构;具有AP的BSS称为基础结构网络;

Ess拓展服务集:由两个或多个具有多个接入点的BSS组成;BSS连接到一个DISTRIBUTION SYSTEM分配系统DS,分配系统连接网络的AP;

2)站类型分类:ess切换:可以从当前ESS移动到其他ESS;

bss切换:在一个ESS控制下的多个BSS范围内移动;

无切换:在一个BSS范围内移动或者固定不动;

3) MAC子层:

4) 定义两种子层:

5) 常用为在csma with collision avoidance带碰撞避免的载波侦听多点接入CSMA/CA的MAC子层:

6) 帧交换时序:10

7) 源站在发送帧之前,检查信道是否空闲,如果忙,使用带退避的坚持策略等待信道空闲,如果空闲则先等待DIFS分布帧间距distributed interframe space的时间,然后发送称为请求发送的请求帧RTS;目的站收到以后,等待SIFS短帧间距short interframe space,然后回送CTS允许发送的数据帧,源站收到后等待DIFS时间后发送数据,接收方收到后等待SIFS时间后后发送确认;

8) 网络分配矢量:802.11协议使用NAV网络分配矢量network allocaation vector解决碰撞问题;站点发送帧时,在帧中标识需要占用信道的时间,涉及站点需要创建一个定时器NAV,标识其他站检测信道是否空闲前必须等待时间;

在传送RTS或者CTS控制帧之前,通常称为握手期,发生了碰撞,如果没有收到CTS帧。认为发生了碰撞;

IP层协议

IPV4协议:

路由器2,3,5都安装WIC-2T模块,将其拖动到右边端口上;

05105325a2e74d06b8f3651ca4fcb6d3.png

网络结构如图所示:

16034d308c1643b5bc829edc9a94de9d.png

e082e09d0ded4a6d98d378b98e07752b.png

对路由器3:

Router>enable

Router#conf

Router#configure ter

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int

Router(config)#interface fa

Router(config)#interface fastEthernet 0/0

Router(config-if)#ip address 192.168.4.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#inter

Router(config)#interface se 0/0

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0, changed state to down

Router(config-if)#exit

Router(config)#interface se0/1

Router(config-if)#ip address 192.168.3.2 255.255.255.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/1, changed state to down

Router(config-if)#exit

Router(config)#router rip

Router(config-router)#version 2

Router(config-router)#network 192.168.1.0

Router(config-router)#network 192.168.3.0

Router(config-router)#network 192.168.4.0

Router(config-router)#exit

Router(config)#exit

Router#

%SYS-5-CONFIG_I: Configured from console by console

write

Building configuration...

[OK]

Router#write

Building configuration...

[OK]

Router#

4c23b0bff29e44e5bf30c0a0e0a6ca8c.png

配置路由器2:

Router>enable

Router#con

Router#conf

Router#configure ter

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface se0/0

Router(config-if)#ip address 192.168.2.1 255.255.255.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0, changed state to down

Router(config-if)#exit

Router(config)#intterface se0/1

^

% Invalid input detected at '^' marker.

Router(config)#interface se0/1

Router(config-if)#ip address 192.168.1.2 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface Serial0/1, changed state to up

Router(config-if)#exit

Router(config)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up

Router(config)#router rip

Router(config-router)#version 2

Router(config-router)#network 192.168.1.0

Router(config-router)#network 192.168.2.0

Router(config-router)#exit

0f898669912b495ea29f81546c519a82.png

配置路由器5:

Router>enable

Router#confi

Router#configure ter

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface se0/1

Router(config-if)#ip address 192.168.3.1

% Incomplete command.

Router(config-if)#ip address 192.168.3.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface Serial0/1, changed state to up

Router(config-if)#exit

Router(config)#i

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up

Router(config)#interface se0/0

Router(config-if)#ip address 192.168.2.2 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface Serial0/0, changed state to up

Router(config-if)#exit

Router(config)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

i

% Ambiguous command: "i"

Router(config)#interface fa0/0

Router(config-if)#ip address 192.168.5.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#router rip

Router(config-router)#version 2

Router(config-router)#network 192.168.2.0

Router(config-router)#network 192.168.3.0

Router(config-router)#network 192.168.5.0

7cbe347c1df944e790eb7b2720f21f37.png

配置路由器4

Router>enable

Router#conf

Router#configure ter

Router#configure terminal

Router(config)#interface fastEthernet 0/0

Router(config-if)#ip address 192.168.4.2 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#ip default-gateway 192.168.4.1

配置路由器6

Router>enable

Router#con

Router#conf

Router#configure ter

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#inter

Router(config)#interface fa

Router(config)#interface fastEthernet 0/0

Router(config-if)#ip address 192.168.5.2 255.255.255.0

Router(config-if)#no shutdown

Router(config)#ip default-gateway 192.168.4.1

 

 

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.xdnf.cn/news/1545429.html

如若内容造成侵权/违法违规/事实不符,请联系一条长河网进行投诉反馈,一经查实,立即删除!

相关文章

低成本搭建企业专属云电脑 贝锐向日葵推出私有化云电脑服务

作为一种硬件虚拟化技术,云电脑的优势是十分显著的,比如可以随时随地访问,拥有较高的性能、无需我们购买昂贵的实体硬件、计算资源可以按需灵活拓展等等。 如今,越来越多的企业也开始认识到云电脑所带来的优势,将云电…

视频压缩怎么操作?3款工具轻松告别内存不足的困扰

是不是越来越多的朋友都在用视频记录日常的点滴啊? 是不是想着把视频发到分享平台上,却发现视频的时长超过了平台的限制,没办法直接上传? 想找好用的视频压缩软件手机版,却发现都是需要付费的? 别急&…

基于springboot在线点餐系统

基于springbootvue实现的点餐系统 (源码L文ppt)4-077 第4章 系统设计 4.1 总体功能设计 一般个人用户和管理者都需要登录才能进入点餐系统,使用者登录时会在后台判断使用的权限类型,包括一般使用者和管理者,一般使用…

vue3的生命周期有哪些

vue3的生命周期:1、beforecreate;2、created;3、beforemount;4、mounted;5、beforeupdate;6、updated;7、beforedestroy;8、destroyed;9、activated;10、deac…

STM32基础学习笔记-DHT11单总线协议面试基础题7

第七章、DHT11: 单总线协!议 常见问题 1、DHT11是什么 ?有什么特性 ? 2、单总线协议是什么 ?原理 ?DHT11的单总线协议的组成 ? ## 1、DHT11定义 单总线协议是一种用于在多个设备之间进行通信的协议,所有…

Calcite第一课

Calcite 是什么? 2024 年 9 月,最新版本 1.37.0 。前面三节我们先不看任何的源码,只从背景、介绍、概念、原理层面入手,作为深入学习和源码分析的预备。 如果用一句话形容 Calcite,Calcite 是一个用于优化异构数据源的…

2024年CSP-J认证 CCF信息学奥赛C++ 中小学初级组 第一轮真题-阅读程序题解析

2024 CCF认证第一轮&#xff08;CSP-J&#xff09;真题 二、阅读程序题 (程序输入不超过数组或字符串定义的范围&#xff0c;判断题正确填√错误填X;除特殊说明外&#xff0c;判断题 1.5分&#xff0c;选择题3分&#xff0c;共计40 分) 第一题 01 #include <iostream>…

【C++进阶】2024年了set、map还搞不懂底层细节?

&#x1f680;个人主页&#xff1a;小羊 &#x1f680;所属专栏&#xff1a;C 很荣幸您能阅读我的文章&#xff0c;诚请评论指点&#xff0c;欢迎欢迎 ~ 目录 一、前情提要1、什么是关联式容器&#xff1f;2、键值对又是什么&#xff1f; 二、树形结构的关联式容器1、set1.1…

在不受支持的 Mac 上安装 macOS Sequoia (OpenCore Legacy Patcher v2.0.1)

在不受支持的 Mac 上安装 macOS Sequoia (OpenCore Legacy Patcher v2.0.1) Install macOS on unsupported Macs 请访问原文链接&#xff1a;https://sysin.org/blog/install-macos-on-unsupported-mac/&#xff0c;查看最新版。原创作品&#xff0c;转载请保留出处。 作者主…

【CoppeliaSim V4.7】The Python interpreter could not handle the wrapper script

[sandboxScript:error] The Python interpreter could not handle the wrapper script (or communication between the launched subprocess and CoppeliaSim could not be established via sockets). Make sure that the Python modules ‘cbor2’ and ‘zmq’ are properly i…

【C++】stack和queue的使用及模拟实现

stack就是栈的意思&#xff0c;这个结构遵循后进先出(LIFO)的原则&#xff0c;可以将栈想象为一个子弹夹&#xff0c;先进去的子弹后出来。 queue就是队列的意思&#xff0c;这个结构遵循先进先出(FIFO)的原则&#xff0c;可以将对列想象成我们排队买饭的场景&#xff0c;先排…

Shopee 大促想爆单如何准备?EasyBoss ERP为你准备了一份攻略!

Shopee下半年第二个大促节点——10.10品牌大促即将来到&#xff0c;根据Shopee的官方的数据&#xff0c;9.9大促当天&#xff0c;Shopee Mall单量增至平日4倍。 老板们&#xff0c;准备好自己的热卖爆款冲击10.10大促了吗&#xff1f; 图源&#xff1a;Shopee 为助力大家迎战大…

大模型速通LLM神书来了《从头开始构建大型语言模型》,尚未发布,GitHub标星22k!!

这本大模型书籍资料已经上传CSDN&#xff0c;朋友们如果需要可以微信扫描下方CSDN官方认证二维码免费领取【保证100%免费】 本书介绍 《从零构建大模型》是一本即将于今年10月底发布的书籍&#xff0c;github已经吸引了惊人的21.7k标星&#xff01;作者是威斯康星大学麦迪逊分…

N个utils(类加载-初始化-序列化)

fasterxml.jackson.databind.ObjectMapper(springboot本身就集成了) public class ObjectMapper {// 公共的ObjectMapper对象public static com.fasterxml.jackson.databind.ObjectMapper mapper new com.fasterxml.jackson.databind.ObjectMapper();/*** Description: 将数据…

推荐一款开源的链路监控系统

12.9k star&#xff0c;最强链路监控系统推荐&#xff0c;推荐 用过cat、pinpoint、skywalking等链路监控系统&#xff0c;各有优劣&#xff0c;但用的最多的还是pinpoint&#xff0c;工作6年&#xff0c;其中有4年都在用pinpoint&#xff0c;所以也比较熟悉&#xff0c;之前也…

鸿蒙界面开发——组件(10):单选框Radio复选框checkbox 下拉框select 多条件筛选Filter

单选框Radio 单选框一直会有这个圆圈&#xff0c;在选中和未选中之间切换状态。 Radio通过调用接口来创建&#xff0c;接口调用形式如下&#xff1a; Radio(options: RadioOptions) Radio(options: {value: string, group: string ,indicatorType:RadioIndicatorType,(新增) …

NET 7 AOT 的使用以及+NET 与 Go 互相调用

目录 背景 C# 部分 环境要求 创建一个控制台项目 体验 AOT 编译 C# 调用库函数 减少体积 C# 导出函数 C# 调用 C# 生成的 AOT Golang 部分 安装 GCC Golang 导出函数 .NET C# 和 Golang 互调 C# 调用 Golang Golang 调用 C# 其他 背景 其实&#xff0c;规划这篇文章有一段时间了…

AI产品经理必知的133个专业术语

一、机器学习与数据科学 1、监督学习&#xff08;Supervised Learning&#xff09; 监督学习是机器学习的一种形式&#xff0c;其中模型通过带标签的数据集进行训练。训练数据包括输入特征&#xff08;X&#xff09;和对应的输出标签&#xff08;Y&#xff09;&#xff0c;模…

哪个牌子的麦克风好?选购无线麦克风必看的五大隐藏风险

随着短视频行业的兴起。短视频已经成为我们日常生活的一个重要表达载体&#xff0c;同时无线麦克风也是正式进入到了我们的视野之中&#xff0c;这种麦克风凭借没有线材束缚、兼容性更好、拾音更好的特性&#xff0c;成为了不少短视频创作者必不可少的“搭档之一”&#xff0c;…

uniapp APP自动更新组件

在uniapp中实现APP自动更新功能&#xff0c;主要涉及到客户端在功能不断迭代过程中&#xff0c;需要进行自动更新。uniapp一个详细的实现步骤&#xff0c;包括客户端和服务器端的配置&#xff1a; 服务器端配置 版本信息管理 服务器端需要维护一个数据库或配置文件&#xff…